• Friday, November 6, 2020

We have been notified that a recent MariaDB upgrade to v10.2.35 or v10.3.26 is causing the cPanel UI not to read the grants properly on the application running upstream unsupported PHP v7.2 and lower.

This may cause such a website to be inaccessible and the MySQL Database page within the cPanel interface to return something like the following error:

cpanel-mariadb-issue

Since we have adequate safeguards in place for most production servers, we believe that this will ONLY impact a small subset of users.

While the cPanel development team works towards a permanent resolution, we have implemented a workaround to prevent this from affecting your application.

If you are hosting an application with older PHP versions and come across this issue, please do let our technical support know so we can take a second look at it.

 

Thanks.